首页 > 资源分享 > 正文
利用HTML5 Shiv解决低版本浏览器html5兼容性问题

最新新写了一份主题,各种细节都优化完毕之后,为了不影响原站的seo,进行的阶梯式的更换,不管是速度还是页面优化情况都比老版好用了不少,但是在偶然用了IE8浏览器之后遇到问题,因为写主题的时候使用的主要还是chrome,虽然有用到某个版本的IE做兼容性测试,但是因为没有关注是IE多少,也没有管太多,发现问题之后才发现用来测试的是IE11,而IE8以及以下版本的浏览器是不支持html5标签的,所以IE8下的凄惨程度也就可想而知了,解决方法如下:

 

HTML5 Shiv,的诞生就是为了解决低版本IE浏览器对html5的支持问题,使用方法为将以下代码添加到当前主题的head部分,注意必须是head,在其他位置引用的话就没效果了。

 <!--[if lt IE 9]>
 <script src="//cdn.bootcss.com/html5shiv/3.7.3/html5shiv.min.js"></script>
 <![endif]-->

这里面的js文件是公共库的cdn,也可以下载文件到本地使用。

文章评论

共有 1 条评论

  1. 优璇

    嘿嘿,回个贴表明我来过。

Top